zstore no longer working?
Posted: Tuesday, July 09, 2019 7:57:42 PM
So my feeds have been dead for quite some time. Did zazzle end their support for the zstore?
Posted: Tuesday, July 09, 2019 8:50:48 PM
If I remember correctly ZSB has been unsupported for years.
Posted: Wednesday, July 10, 2019 5:07:43 PM
Hi @levelasian,

We made changes to our URL structure recently and all RSS feeds need to be updated to the new folder structure.

If you haven't already, please update the zstore.php code to include in the feed path: /store/contributorHandle, instead of just /contributorHandle

The default line that should be changed is the following line:
// URLS used by the Zazzle Store Builder
$dataURLBase = $contributorHandle!="" ? 'https://feed.'.$zazzleURLBase.'/'.$contributorHandle.'/feed' : 'https://feed.'.$zazzleURLBase.'/feed';


It needs to be updated to:
$dataURLBase = $contributorHandle!="" ? 'http://feed.'.$zazzleURLBase.'/store/'.$contributorHandle.'/feed' : 'http://feed.'.$zazzleURLBase.'/feed';

Hope this fixes the issue.

Thanks!
Elizabeth P.
Posted: Thursday, July 11, 2019 9:33:41 AM
Elizabeth P. wrote:

We made changes to our URL structure recently and all RSS feeds need to be updated to the new folder structure.

Could changes like this be reported to designers when they happen instead of always leaving us in the dark? My affiliate shop was dead for a month and I had to remove zstore because I didn't think anyone had an answer as to why it was no longer working.
Crying
Posted: Thursday, July 11, 2019 1:32:02 PM
Hi there, my file had different wording on the line, so I had to tweak it in order for it to work. Also I changed second line.

Before
Quote:
$dataURLBase = $contributorHandle!="" ? 'https://feed.zazzle.com/'.$contributorHandle.'/feed' : 'https://feed.zazzle.com/feed';
$zazzleURLBase = 'http://www.zazzle.com';


After
Quote:
$dataURLBase = $contributorHandle!="" ? 'https://feed.zazzle.com/'.'/store/'.$contributorHandle.'/feed' : 'https://feed.zazzle.com/feed';
$zazzleURLBase = 'https://www.zazzle.com';


THANK YOU!!!

Posted: Thursday, July 11, 2019 5:45:11 PM
Dementees wrote:
Elizabeth P. wrote:

We made changes to our URL structure recently and all RSS feeds need to be updated to the new folder structure.

Could changes like this be reported to designers when they happen instead of always leaving us in the dark? My affiliate shop was dead for a month and I had to remove zstore because I didn't think anyone had an answer as to why it was no longer working.
Crying
I am sorry that this adversely affected your site, but to claim that Zazzle is "always leaving us in the dark," is completely unsupported nonsense.

First: the URL structure update was announced in the News forum when the change was made:
https://forum.zazzle.com/news/updated_zazzle_store_url_organization

Second: if you run a website it's your own responsibility to ensure that everything is running correctly. If you find that an external service is not working properly (in your case, it is/was Zazzle feeds) then you should probably ask them about it. We run into the same issues ourselves with our social media integrations (among other things), and occasionally need to reach out to external service providers for assistance.

So in this case it really sounds like you (A) didn't check the News forum, and (B) never asked any questions when you discovered that something wasn't working properly. This issue is totally avoidable in the future, you just need to ask questions. There is absolutely nothing wrong with asking questions.

I understand the sentiment that perhaps Zazzle should have also proactively explained how this might affect feeds, and I agree that we should have probably added in information about that. But it doesn't seem like you read the News post about this anyways, so...

My suggestion to everyone is to keep an eye on the News forum. That's where we've been announcing changes to the website that are of interest to Designers. We have some really amazing products in the works now that you guys should really love.
Posted: Thursday, July 11, 2019 5:48:46 PM
I am going to leave this discussion open, but let's please keep things on topic.

If you have a question feel free to ask, and if you're interested in providing useful information (like sumwoman did above) then go for it.
Posted: Friday, July 12, 2019 10:44:10 AM
I'm glad I found this post. Good to know. I must have missed the e-mail that was sent out informing everyone of the change.
Posted: Monday, August 26, 2019 9:49:39 AM
okay, will try to fix this. I don't remember all my passwords so my site has been dead for a while due to the feed error.
Posted: Monday, August 26, 2019 10:20:18 AM
Still not working for me. Do I have to do something different if I'm using the Zstore plugin for Wordpress?
Posted: Monday, August 26, 2019 10:39:47 PM
sumwoman wrote:
Hi there, my file had different wording on the line, so I had to tweak it in order for it to work. Also I changed second line.

After
Quote:
$dataURLBase = $contributorHandle!="" ? 'https://feed.zazzle.com/'.'/store/'.$contributorHandle.'/feed' : 'https://feed.zazzle.com/feed';
$zazzleURLBase = 'https://www.zazzle.com';


THANK YOU!!!



Thanks! This version fixed it! Was thinking about closing my site, but this fix will keep it up running for a little longer until I find out what I want to do next.
Users browsing this topic
Guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.
Print this topic
RSS Feed
Normal
Threaded