Twitter card validator reports that robots.txt denies access when url params included
Posted: Sunday, August 25, 2019 2:47:04 AM
Images on my tweets stopped showing images around 12 hours ago.
I used the Twitter card validator here:
https://cards-dev.twitter.com/validator
When giving it a url of the normal form I use:
Code:
https://www.zazzle.com/modern_slate_business_card-240916516133478294?rf=238582202591969585&tc=nnip_progifts_crbnhnry_twtr_082519&pm=

I get a message:
Quote:
The card for your website will look a little something like this!
Unable to render Card preview
Log
ERROR: Fetching the page failed because it's denied by robots.txt.

When I use a url without the url parameters, all is good
Code:
https://www.zazzle.com/modern_slate_business_card-240916516133478294

Quote:

Log
INFO: Page fetched successfully
INFO: 24 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully

When I use a url without the associate / referral id but including a tracking code, again all is well:
Code:
https://www.zazzle.com/modern_slate_business_card-240916516133478294?tc=nnip_progifts_crbnhnry_twtr_082519

Quote:

Log
INFO: Page fetched successfully
INFO: 24 metatags were found
INFO: twitter:card = summary_large_image tag found
INFO: Card loaded successfully

When I use a url with only the associate / referral id as a url parameter, again it fails:
Code:
https://www.zazzle.com/modern_slate_business_card-240916516133478294?rf=238582202591969585

Quote:

The card for your website will look a little something like this!
Unable to render Card preview
Log
ERROR: Fetching the page failed because it's denied by robots.txt.

I hope you're able to sort this quickly Smile

The Facebook debugger (the equivalent of Twitter's card validator) is ok with an included associate / referral id.
Code:
https://developers.facebook.com/tools/debug/

Posted: Sunday, August 25, 2019 6:17:34 AM
I noticed that yesterday. Twitter is difficult enough to get Zazzle images to show on a normal day. Now it's impossible unless you leave off your referral.
Posted: Sunday, August 25, 2019 11:57:19 AM
I thought I saw Scott post something similar to this a few days ago

something about referral links breaking the post. but I can't find it now.
Posted: Sunday, August 25, 2019 11:59:25 AM
Posted: Monday, August 26, 2019 8:07:47 AM
Working now. Thanks!
This thread can be closed.
Posted: Monday, August 26, 2019 8:08:45 AM
Posted: Wednesday, August 28, 2019 2:14:32 AM


Scott,
It's broken again with the same problem as before - the twitter card validator fails when an rf id is included in the url parameters. When it's removed the card validator succeeds and the image is displayed.
Posted: Wednesday, August 28, 2019 8:50:26 AM
We probably don't need two of these discussions. Feel free to use the other discussion since it has a bunch of product examples already.
Users browsing this topic
Guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.
Print this topic
RSS Feed
Normal
Threaded