Image Links Not Showing on Twitter 2 pages: 1 [2]
Posted: Saturday, August 31, 2019 1:01:55 PM
Zorinda wrote:
So, armed with this new info Shelli so kindly provided on how to properly share to Twitter, I gave it a shot. Unfortunately none of the products or collections I posted show images. Hopefully between Zazzle and Twitter someone will figure out a timely fix. Fingers crossed.


My tweets are hit and miss with the images right now too.
Posted: Saturday, August 31, 2019 7:35:03 PM
Zorinda wrote:
So, armed with this new info Shelli so kindly provided on how to properly share to Twitter, I gave it a shot. Unfortunately none of the products or collections I posted show images. Hopefully between Zazzle and Twitter someone will figure out a timely fix. Fingers crossed.


+1
Posted: Saturday, August 31, 2019 8:24:42 PM
I have not been using the share button and have been copy/pasting the product url without my referral code. I seldom get a referral anyway and I would rather the picture show up consistently. I also check the links in Twitter card validator before posting. Sometimes you have to run it though that a couple of times for the image to show.
Posted: Sunday, September 01, 2019 5:19:54 AM
Last night I added a few products and collections to Twitter using the share button. This time I deleted the referral code before submitting and the images popped right up. Kind of seems like that's the offender.

Sunday afternoon update: Removing the code is no longer working. With or without the referral code I can’t get image to show. Sad
Posted: Sunday, September 01, 2019 5:56:44 PM
I don't know if this has to do with anything but over the last few days, I have been unable to get a photo to post before 9 or 10 am Pacific time and then fine all day until 5 in the evening. Probably just the luck of it but thought I would mention it just in case.
Posted: Wednesday, September 04, 2019 10:53:01 AM
It's still hit and miss on twitter for me. Yesterday I could promote the mug sale with images...today the post card sale isn't getting images. I use the share buttons. Sad
Posted: Wednesday, September 04, 2019 11:56:37 AM
Yep, still very hit and miss. I turned off my IFTTT applets so I wouldn't keep tweeting products with no images. But, I also have had trouble using the share button on the Zazzle product pages. example using share button https://twitter.com/angelandspot/status/1169338730047557632
Posted: Wednesday, September 04, 2019 12:07:26 PM
Same... it worked for me last night & about 12 hours ago, but the product I posted just now has no image. It doesn't matter if I use the share button or post the link directly.
Posted: Thursday, September 05, 2019 7:56:18 PM
I have the problem too. I was tweeting my products without checking twitter for days and had no idea there was a problem. Looks like I've had no images since at least Aug 31, maybe earlier.
Posted: Sunday, September 08, 2019 4:15:49 PM
Just tried sharing products via Twitter (first time in about a week). Images aren't appearing for me, either.
Posted: Sunday, September 08, 2019 6:04:21 PM
Zorinda wrote:
So, armed with this new info Shelli so kindly provided on how to properly share to Twitter, I gave it a shot. Unfortunately none of the products or collections I posted show images. Hopefully between Zazzle and Twitter someone will figure out a timely fix. Fingers crossed.

+1
Posted: Sunday, September 08, 2019 10:34:30 PM
Sad Sad Sad Sad
Posted: Monday, September 09, 2019 12:03:18 AM
Zazzle please take note of Hightens Reply!! It's defnitely a problem on Zazzle's end as the Twitter Card Validator shows. More info in this thread:
https://forum.zazzle.com/technical/twitter_card_validator_reports_that_robots_txt
Posted: Monday, September 09, 2019 6:22:44 AM
Not sure if this helps you all but when I use the share button to pin to Pinterest and then in the Pinterest Screen tick the box "Post to Twitter", everything works fine, images are visible on Twitter :-)
Posted: Monday, September 09, 2019 6:33:46 AM
Well, days later and it is not fixed.

https://twitter.com/angelandspot/status/1171068801326227456

I guess I have to give up on trying to tweet Zazzle products and only promote my other POD stores on twitter.
Posted: Monday, September 09, 2019 8:39:20 AM
I'm done, stopped sharing on Twitter. After the collections have been miss for most of the time and now also individual tweets ... Crying
Posted: Monday, September 09, 2019 9:09:42 AM
I am very disappointed that this is still happening. Twitter is one of the 2 SM I still use so this cuts my promotions in half. Sad
Posted: Monday, September 09, 2019 9:29:41 AM
yoursparklingshop wrote:
Not sure if this helps you all but when I use the share button to pin to Pinterest and then in the Pinterest Screen tick the box "Post to Twitter", everything works fine, images are visible on Twitter :-)


But it takes them to Pinterest, my goal is to get them to Zazzle (with fewer clicks) to make a sale.
Posted: Monday, September 09, 2019 9:30:32 AM
Shelli Fitzpatrick wrote:
I am very disappointed that this is still happening. Twitter is one of the 2 SM I still use so this cuts my promotions in half. Sad


Same.
Posted: Monday, September 09, 2019 10:54:52 AM
It worked on and off over the weekend but not at all today for me. This seems like a pretty big thing that perhaps we could at least get an update on please. It has been going on for quite some time.

Posted: Wednesday, September 11, 2019 7:50:27 AM
It appears to be a problem specific to Zazzle images. Even some Zazzle images that were showing previously on Twitter are no longer showing. I never have any problems with my own images and haven't noticed disappearing images from other links. One from Zazzle that I had given prominence by pinning to the top is among those now blank so I replaced with my own image and the photo appeared right away in the tweet. Hopefully Zazzle can get this and other tech issues fixed soon.
Posted: Friday, September 13, 2019 2:49:16 PM
I've only been using nIFTTTy Scheduler to tweet. To see if it's time / day dependent, I switched to tweeting once every hour. Every tweet has had an image for the last 21 hours. Before that none had.
You can keep en eye on it yourself, here: https://twitter.com/hightonridley
Posted: Sunday, September 15, 2019 6:45:49 AM
Is anyone still having trouble with this? Since 13th Sept, every tweet by nIFTTTy has included the image just fine. That's one every hour, so it looks like it's fixed.
Hope I'm not speaking too soon!
Laughing Laughing
Posted: Sunday, September 15, 2019 11:12:05 AM
I seems to be working fine for me from the Zazzle share buttons.
Posted: Sunday, September 15, 2019 2:54:52 PM
Been working for the last few days so we will see. I hope fixed.
Posted: Sunday, September 15, 2019 8:46:28 PM
I spoke too soon...it is still hit and miss.
Posted: Monday, September 16, 2019 8:25:05 AM
Another thrilling game of cat-and-mouse has come to a close.

This will be fixed when we update our website tomorrow.

Locking this discussion for now. I'll update it when there's an update.
Users browsing this topic
Guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.
Print this topic
RSS Feed
Normal
Threaded