Image Links Not Showing on Twitter 2 pages: [1] 2
Posted: Sunday, August 25, 2019 5:40:37 PM
I don't know if this is a problem on Zazzle's end or Twitter's, but when posting links from a product page, the images are not showing.
Posted: Sunday, August 25, 2019 5:57:37 PM
I just came on to see if anyone else was having a problem. It has been hit or miss for me over the last few days and mostly miss. I am guessing on Twitter side but don't know. I do use the little share icon under the product for Twitter. Not sure if there is even another way to tweet a product.
Posted: Monday, August 26, 2019 8:03:17 AM
Works for me. Is this still an issue for you guys?
Posted: Monday, August 26, 2019 9:25:18 AM
At times it works and others not but more often still not.
Posted: Monday, August 26, 2019 11:16:59 AM
Some do and some don't. This weekend Zero did so I have tons of scheduled tweets that don't have images. Not sure if I should delete those tweets or just leave them and hope someone clicks the link?
Posted: Monday, August 26, 2019 11:39:15 AM
Can each of you link me to five products that do not work as you expect?
Posted: Monday, August 26, 2019 12:15:43 PM
Posted: Monday, August 26, 2019 12:28:31 PM
Posted: Monday, August 26, 2019 12:39:28 PM
Posted: Monday, August 26, 2019 5:26:46 PM
Mine are all working now today! Thanks!
Posted: Tuesday, August 27, 2019 10:16:56 AM
This should be working fine now, but your older/existing tweets may not contain an image. Not much we can do about that. This issue appears to have been on Twitter's end.

Here's another explanation - https://forum.zazzle.com/technical/twitter_card_validator_reports_that_robots_txt

I've checked a handful of the example products that were posted here and emailed to the Support team, and they all seem to be working just fine.

If any future tweets do not contain images please post the product (or tweet) here.
Posted: Tuesday, August 27, 2019 5:33:09 PM
It still seems to be hit or miss. I have a tweet from just 1 hr ago not showing an image but then I have tweets from earlier today that do have images.

This tweet https://twitter.com/angelandspot/status/1166493005844492288 for a product that is not one of mine rather one that I was promoting does not show an image.

The link used is https://www.zazzle.com/mexican_fiesta_sweet_16_roosters_folk_flowers_invitation-256225243263679266?rf=238612366606874150&tc=twitter_Rooster_082719&pm=


Posted: Tuesday, August 27, 2019 5:58:35 PM
All worked today except my last one of the day.

https://twitter.com/AZNatureInFocu1/status/1166515864721485825
Posted: Tuesday, August 27, 2019 6:50:45 PM
Well that's no good.

Thanks for the examples. If you do happen to come across 2-3 more then that might be helpful. I wouldn't stop what you're doing to find examples, though.
Posted: Tuesday, August 27, 2019 7:42:00 PM
Just letting you know that all the tweets I had yesterday with no images now have images back. I didn't report them because I could never get 5 of them. But anyway they are back to normal tonight.
Posted: Wednesday, August 28, 2019 4:44:26 AM
A few more examples:

https://twitter.com/MagicalUnicorns/status/1166686195973271555
https://twitter.com/MagicalUnicorns/status/1166656120146018306
https://twitter.com/MagicalUnicorns/status/1166625781440765955
https://twitter.com/MagicalUnicorns/status/1166595603364753408
https://twitter.com/MagicalUnicorns/status/1166474779651710976

Wondering if it is IFTTT messing up, twitter, or zazzle as these were all scheduled pins to run in the overnight and early morning hours. But then others from the same day do show images? Like this one. https://twitter.com/MagicalUnicorns/status/1166414369749635073 I was trying to promote other unicorn items since it is a unicorn twitter account.
Posted: Wednesday, August 28, 2019 4:46:43 AM
Posted: Wednesday, August 28, 2019 4:50:45 AM
It's defnitely a problem on Zazzle's end as the Twitter Card Validator shows. More info in this thread:
https://forum.zazzle.com/technical/twitter_card_validator_reports_that_robots_txt
Posted: Wednesday, August 28, 2019 8:55:47 AM
Not so sure about it being on Zazzle's end. A few days ago when this issue originally popped up it was (mostly) fixed without any work from Z's end (to my knowledge, at least). Either way, I created a ticket for this last night before I went home so we'll see what engineering says. Maybe there's a quick fix we can make that will bring things in line with any changes that Twitter might have recently made. As some of you guys know, working with other service providers can get tricky.

For now I don't need any additional examples. Thanks to everyone who has provided them. I'll leave this conversation unlocked, and provide updates as they become available.
Posted: Wednesday, August 28, 2019 4:52:40 PM
HightonRidley wrote:
It's defnitely a problem on Zazzle's end as the Twitter Card Validator shows. More info in this thread:
https://forum.zazzle.com/technical/twitter_card_validator_reports_that_robots_txt
TY Mark, very helpful. Was just able to post with image to Twitter after several days of no images.
Posted: Thursday, August 29, 2019 9:23:41 AM
Posted: Thursday, August 29, 2019 9:42:12 AM
Can you post a link to a tweet that shows the IFTTT link working properly with a Zazzle image and all?
Posted: Thursday, August 29, 2019 9:48:12 AM
MixedMedia13 wrote:
Wondering if it is IFTTT messing up, twitter, or zazzle as these were all scheduled pins to run in the overnight and early morning hours. But then others from the same day do show images? Like this one. https://twitter.com/MagicalUnicorns/status/1166414369749635073 I was trying to promote other unicorn items since it is a unicorn twitter account.
This is what I'm thinking.

Zazzle can control Zazzle's own code, but integrations can make things very tricky to troubleshoot.

There is currently an issue posting Zazzle images directly to Twitter, so that will need to be sorted out first.
Posted: Thursday, August 29, 2019 9:49:00 AM
Posted: Thursday, August 29, 2019 10:18:45 AM
Thanks
Posted: Friday, August 30, 2019 2:04:22 PM
I haven't done much sharing Zazzle links on Twitter but I'm gonna start. I have a few questions for the posting experts.

Assuming that everything is fixed and working as expected:

When you share product links, are the images just supposed to automatically show up, or do you have to grab and post the separate image url? If you want to add text and / or hashtags, do they interfere with the images coming up? Should you add text before the Zazzle post, after, or should it not matter assuming you're under the character limit?

Are collections any different? Should the images just automatically come up when you hit share and then post?

Thanks!
Posted: Friday, August 30, 2019 2:24:03 PM
Zorinda wrote:
I haven't done much sharing Zazzle links on Twitter but I'm gonna start. I have a few questions for the posting experts.

Assuming that everything is fixed and working as expected:

When you share product links, are the images just supposed to automatically show up, or do you have to grab and post the separate image url? If you want to add text and / or hashtags, do they interfere with the images coming up? Should you add text before the Zazzle post, after, or should it not matter assuming you're under the character limit?

Are collections any different? Should the images just automatically come up when you hit share and then post?

Thanks!


At the risk of getting scolded for chit chatting...

When you are using the share buttons the image should automatically populate your tweet.

You only have to add the URL and image manually and if you are building a tweet from scratch. hope that makes sense and helps!
Posted: Friday, August 30, 2019 3:04:47 PM
Thanks Shelli. My bad. Grin

If they want to delete my post that's fine. Smile
Posted: Friday, August 30, 2019 3:16:46 PM
Zorinda wrote:
Thanks Shelli. My bad. Grin

If they want to delete my post that's fine. Smile


no problem Zorinda! Smile
Posted: Saturday, August 31, 2019 12:37:04 PM
So, armed with this new info Shelli so kindly provided on how to properly share to Twitter, I gave it a shot. Unfortunately none of the products or collections I posted show images. Hopefully between Zazzle and Twitter someone will figure out a timely fix. Fingers crossed.
Users browsing this topic
Guest


Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.
Print this topic
RSS Feed
Normal
Threaded